Segmentation fault classify.seqs

Please report bugs you encounter in mothur using this forum.
Post Reply
vimac
Posts: 3
Joined: Tue Nov 15, 2016 7:48 am

Segmentation fault classify.seqs

Post by vimac » Mon Nov 27, 2017 8:32 am

Dear all,

I have a 'Segmentation fault" problem when running mothur v.1.36.1. I've been using this version without a problem and done most of my analysis with it but suddenly it keeps on crashing during the "classify.seqs" step in batch mode in which I get the following error:

mothur > classify.seqs(fasta=current, count=current, reference=/home/vimac/Databases/Silva/SILVA_128/SSURef_NR99_v128/silva.nr_v128/silva.nr_v128.align, taxonomy=/home/vimac/Databases/Silva/SILVA_128/SSURef_NR99_v128/silva.nr_v128/silva.nr_v128.tax, cutoff=80)
Using G1_cDNAs.stability.trim.contigs.good.unique.good.filter.unique.precluster.denovo.uchime.pick.count_table as input file for the count parameter.
Using G1_cDNAs.stability.trim.contigs.good.unique.good.filter.unique.precluster.pick.fasta as input file for the fasta parameter.

Using 4 processors.
Reading template taxonomy... DONE.
Reading template probabilities... Segmentation fault

When checking at the log file there is not much more info:
Using 4 processors.
Reading template taxonomy... DONE.

I tried re-running old data which worked fine before and it crashes at the same step.

I'm running mothur on a Biolinux 8 with 32GB RAM and 1TB of disk so memory should not be a problem.

Any ideas on how to solve this?

Thank you.

pschloss
Site Admin
Posts: 3137
Joined: Wed Sep 02, 2009 3:40 pm
Location: University of Michigan
Contact:

Re: Segmentation fault classify.seqs

Post by pschloss » Mon Dec 04, 2017 10:53 am

Could you try it with 2 or even 1 processor?

Pat

vimac
Posts: 3
Joined: Tue Nov 15, 2016 7:48 am

Re: Segmentation fault classify.seqs

Post by vimac » Tue Dec 19, 2017 5:36 am

Hi Pat,

I tried running it again with 1, 2 and 8 processors and I always get the same segmentation fault error. I even tried with the mothur example data and it also crashes.

Any idea of how to proceed?

Thanks

pschloss
Site Admin
Posts: 3137
Joined: Wed Sep 02, 2009 3:40 pm
Location: University of Michigan
Contact:

Re: Segmentation fault classify.seqs

Post by pschloss » Thu Dec 21, 2017 9:09 am

Sorry, I missed that you are using v.1.36. You really should update hte version to 1.39.5 and try again.

Pat

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest